29 lines
556 B
Nix
29 lines
556 B
Nix
{
|
|
description = "A very basic flake";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs?ref=nixos-unstable";
|
|
utils.url = "github:numtide/flake-utils";
|
|
};
|
|
|
|
outputs =
|
|
{
|
|
self,
|
|
nixpkgs,
|
|
utils,
|
|
}:
|
|
utils.lib.eachDefaultSystem (
|
|
system:
|
|
let
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
in
|
|
{
|
|
devShell = pkgs.mkShell { buildInputs = with pkgs; [ ]; };
|
|
|
|
packages.${system} = {
|
|
inherit (pkgs) hello;
|
|
default = self.packages.hello;
|
|
};
|
|
}
|
|
);
|
|
}
|