nur/pkgs/rustypaste/default.nix
2025-01-07 01:19:43 +01:00

52 lines
1.1 KiB
Nix

{
lib,
rustPlatform,
fetchFromGitHub,
pkg-config,
openssl,
zstd,
stdenv,
darwin,
}:
rustPlatform.buildRustPackage rec {
pname = "rustypaste";
version = "0.16.0";
src = fetchFromGitHub {
owner = "orhun";
repo = "rustypaste";
rev = "v${version}";
hash = "sha256-Kv6hmqqGY9SssiT/MYmYCZ71N8CHFTT7K4q7eMdQTQU=";
};
cargoHash = "sha256-podM44J7RGpLdPo+yS7clwX6vvvQRllkqPu7UpC/LzI=";
nativeBuildInputs = [
pkg-config
];
doCheck = false;
buildInputs =
[
openssl
zstd
]
++ lib.optionals stdenv.isDarwin [
darwin.apple_sdk.frameworks.CoreFoundation
darwin.apple_sdk.frameworks.CoreServices
darwin.apple_sdk.frameworks.Security
];
env = {
ZSTD_SYS_USE_PKG_CONFIG = true;
};
meta = {
description = "A minimal file upload/pastebin service";
homepage = "https://github.com/orhun/rustypaste";
changelog = "https://github.com/orhun/rustypaste/blob/${src.rev}/CHANGELOG.md";
license = lib.licenses.mit;
maintainers = with lib.maintainers; [ ];
mainProgram = "rustypaste";
};
}